OpenSSL - The Heartbleed Bug
Martin Dines / April 10, 2014

On April 7th a flaw was discovered in specific versions of the OpenSSL software; Dubbed 'Heartbleed' this flaw enabled attackers to gain access to normally inaccessible data.

We detected the vulnerability was present on a small number of our servers. These servers were patched immediately on the 8th.

As a safety precaution we have re-issued all SSL certificates and are recommending users reset their passwords.

Want to know more about Heartbleed?
Is my site vulnerable?

If you have any questions, concerns, or would like to know more please contact us.